CentOS 6でjava-1.7.0-openjdkのupdateに失敗

CentOS 6を使っていて、yum updateしたところ、java-1.7.0-openjdkのupdateがエラーになってしまった。

Downloading Packages:
java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el6_10.x86_64.rpm                           |  27 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PRETRANS scriptlet in rpm package 1:java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el6_10.x86_64
error: lua script failed: /usr/libexec/copy_jdk_configs.lua:272: attempt to index global 'file' (a nil value)
  Verifying  : 1:java-1.7.0-openjdk-1.7.0.191-2.6.15.4.el6_10.x86_64                                 1/1 

Failed:
  java-1.7.0-openjdk.x86_64 1:1.7.0.191-2.6.15.4.el6_10                                                  

Complete!

rootになって、

mkdir -p /var/lib/rpm-state

すれば解決。

【参考URL】 https://access.redhat.com/solutions/3573891

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください